Exciting news! Extended Security Support for Moodle LMS v3.9 is available at Catalyst.

21 November 2023 by Catalyst

As you may know Moodle versions 3.9, 3.11 and 4.0 run out of official security support on 11 December 2023. Our general recommendation is to upgrade your Moodle LMS to version 4.1 as it has security support until 8 December 2025. Learn more here.

Depending on the size and complexity of your Moodle site, undertaking an upgrade can be a considerable project. We have outlined the process and considerations in our recent blog – Moodle 3.9 to 4.1 – why you need to upgrade and what to expect.

With Christmas around the corner and limited resources to complete an upgrade what happens if you don’t have time to upgrade?

The good news is that your site isn’t going to disappear on 12 December.

The bad news is that the longer you leave it the more you open your organisation up to vulnerabilities and degrade the experience of users accessing your courses and content.

Catalyst’s Extended Security Support offers a peace of mind for Moodle clients who need a bit more time to upgrade their v3.9 site to the new supported version – v 4.1.

How does it work?

  • Catalyst will provide you with access to the codebase via a closed git repository
  • Catalyst will backport Moodle 4.1 ‘s security releases to a Catalyst-managed Moodle 3.9 codebase
  • Catalyst will notify you of new backports 7 days after release of 4.1 updates
  • On release, you and/or your Hosting Partner can access, apply and manage the releases and deployments . to your site. Catalyst can provide additional services on request.

Important!

  • Backporting is not the same as the security support that Moodle HQ provides for supported Moodle versions.
  • Catalyst will not provide proactive Moodle 3.9 security testing over and above the backporting.
  • Catalyst will be communicative about all security releases.

Who does this apply to?

Current Moodle v3.9 users who are unable to upgrade to a supported version because of budgetary, timing or resourcing issues.

Do I still need to upgrade?

Yes, this service is designed as an interim measure and good Moodle practice is to use a supported version – Learn more here.

Moodle Partners

Will Catalyst make this available to other Moodle partners to apply to their client sites?

Yes but we will need to talk to you about multi-site application.

Contact Catalyst today to take advantage of this offer.